Error when connecting Chronograf to InfluxDB

influxdb
#1

Good to all boys,

I’m trying things with InfluxDB and I have a problem using Chronograf.

The fact is that when I run “influxd.exe” to run InfluxDB and then I run “influx.exe” to enter the InfluxDB Shell and everything works for me without any problem.

But when using Chronograf, run the file “chronograf.exe” and access the browser to the url “http://localhost:8888/” Chronograf interface appears to me but I do not see any Host.

In other words, the databases that I have created appear to me and so on, but I can neither use them nor make queries or anything else.

I have also tried to access the url that appears in the shell (“localhost:8086”) but I get a “Not Found”.

I don’t want to spam but since I’m a new user and they won’t let me put more than one image in the post. I leave here the post that I have also put in StackOverflow in which I have put more images if it helps you. https://es.stackoverflow.com/questions/251248/error-al-conectar-chronograf-a-influxdb

I don’t know if the problem is in the .conf file or what the problem is.

Many thanks to all :smile:

#2

Hi Jose ,

if you install and start Telegraf your problem will be solved :slight_smile:

#3

I have tried but when I run it by teerminal with the following command “telegraf.exe -config telegraf.conf” I get this and do not let me start

#4

Hi can you try with two dashes ?
Telegraf.exe – config …

#5

Nothing, it still doesn’t work…

Post http://127.0.0.1:8086/query: dial tcp 127.0.0.1:8086: connectex: A connection cannot be established because the target computer expressly denied that connection.

#6

Hi , it is advised to install Telegraf in …/Program Files/ but you can copy your config file to program files/Telegraf to make it work …
Can you create the logfile manually in the given location to see what is written in the logfile when starting Telegraf ?
With the two dashes you are a step further , Telegraf was started but cannot connect to the database … is the database ( influxd) still up and running ?

#7

I don’t know. Anyway I’ve been looking and telegraf is to collect data and pass it on to Influx and all that and I really don’t look for that. My idea is to connect Chronograf to Influx to monitor but the data to monitor I’m going to put them by hand so I don’t need telegraf at all.

#8

Hi , Telegraf was needed to get your host in the host list , I thought that was your main concern ,
It is good that you can solve it ,
Sorry for the misunderstanding
Best regards

#9

Okay! It’s solved!
It was my fault that as it is the first time I use this I have no idea.
I am testing and if I put in the command line “create database …” if it works but when I make a query or directly make a “use mydatabase” gives me an error 400 and that is the problem really

With Chronograf
image
With Shell
image

#10

Yes , in chronograf you cannot use the command ‘use temperatura’ you have to select your source in the gui :slight_smile:
Good luck and have a Nice day !

#11

Yeah, I figured it out. It was what you said Marc.
Thank you so much :smiley::smiley::smiley: