Changed machines, now database not showing

Hi!

I have an old 1.7 instance running on my nuc server for some iot logging.
I want to create a copy of this influxdb instance on another machine so I can play with it.

I copied the InfluxData folder over from the nuc to my main pc and now I try to get it running there.

However even though the catalog structure seems to be the same and I can see my database in the windows when I type show databases in the influx terminal only _internal is shown:

image

What can I do to get my copied instance to use my old database ‘influxtest’?

In my config file i have specified the data directories to all be the folder I copied all the data from the nuc instance:

[meta]
  # Where the metadata/raft database is stored
  dir = "C:/Program Files/InfluxData/influxdb-data/meta"

[data]
  # The directory where the TSM storage engine stores TSM files.
  dir = "C:/Program Files/InfluxData/influxdb-data/data"

  # The directory where the TSM storage engine stores WAL files.
  wal-dir = "C:/Program Files/InfluxData/influxdb-data/data/wal"

But when I start influxd I can see that it uses another data folder in my user folder:

 Using data dir  {"log_id": "0Yt6bHP0000", "service": "store", "path": "C:\\Users\\myusername\\.influxdb\\data"}

Why is it not following the specified paths in the config file?

EDIT:

I tried adding the environment variable INFLUXDB_DATA_DIR and set it to C:\Program Files\InfluxData\influxdb-data

Now this is listed as data directory at the startup of influxdb but my old database is still not showing up…

Installed influx as a service using nssm, info here How To Install InfluxDB on Windows in 2019 – devconnected

And now it works. Don’t understand why