Can't secure database

I’ve created an Influx DB on AWS. I created an admin user per the instructions here: https://docs.influxdata.com/influxdb/v1.2/query_language/authentication_and_authorization/#set-up-authentication

Admin user has been created. Other users created. Privs granted on dbs, etc…

The problem is that I can still connect to the DB without authentication. This works, for example (Ruby client)

influxdb = InfluxDB::Client.new host: "ec2-54-146-135-50.compute-1.amazonaws.com"

How can I prevent open connections to my Influx instance?

@gmoore looks like you haven’t set the [http] auth-enabled = true section in your configuration file and restarted. Can you try that?