Can't install InfluxDB from repos.influxdata.com on Ubuntu 20.04

I added InfluxData’s repository for Ubuntu packages using the instructions given at docs.influxdata.com/influxdb/v1.8/introduction/install/. I added the repo on a Ubuntu 20.04 installation, so my sources.list entry looks like this:

# InfluxData Repository
deb https://repos.influxdata.com/ubuntu focal stable

But when I tried to install InfluxDB, I couldn’t do so. The only package that I’m able to install from that repository is Telegraf.

I visited the repos.influxdata.com site on my browser and noticed that the Packages file for Ubuntu 20.04 under binary-amd64 was only showing the Telegraf package, but the Packages file for the previous Ubuntu version (Eoan) under binary-amd64 is showing all the other packages. Could someone at InfluxData get the repository for Focal Fossa updated as well?

Thanks a lot.

Here’s the Packages file for Ubuntu 20.04 (Focal): https://repos.influxdata.com/ubuntu/dists/focal/stable/binary-amd64/Packages

And here’s the Packages file for Ubuntu 19.10 (Eoan): https://repos.influxdata.com/ubuntu/dists/eoan/stable/binary-amd64/Packages

I notice that the repository for Ubuntu 20.04 (focal) which was released two months ago now contains chronograf, kapacitor and telegraf but still no influxdb. Does anyone know if this is just an oversight or is there a problem of some sort?