Cannot Delete From Cloud Hosted Serverless

I just created a new InfluxDB database on the Serverless cloud hosted service, and I’d like to delete data points from a bucket.

I’ve tried every formulation of delete commands, queries, and API calls, but none of them work.

influx delete --org-id <snipped> --bucket <snipped> --start 2020-01-01T00:00:00Z --stop 2023-06-09T10:00:00Z  --predicate '_measurement="editor.reload_times"'

I’ve tried similar through the HTTP API. Both of these return success, but don’t actually do anything, and no data is deleted.

I’ve also tried various queries through the query editor, but all of them fail with either syntax issues, or ‘unsupported’:

DELETE FROM bucket_name;
DELETE * FROM measurement_name

Etc, etc.

How do I actually delete data points?

Any help? … are people able to delete data points? This seems like a really basic feature.

I’ve also tried without any predicate:
influx delete --org-id <snipped> --bucket <snipped> --start 2020-01-01T00:00:00Z --stop 2023-06-09T10:00:00Z

Even that doesn’t work. :\

Hello? Anyone else having this problem?

Hello @kleptine,
Hmm thank you so much for bringing this to our attention.
First what version of the CLI are you using?
It looks like you need:

If you’re still using that version, can you please submit a bug here:

Thank you!

Hello @Anaisdg ,

Is delete possible in Influx cloud serverless?

The documentation is a bit confusing, this page states that the delete api has been disabled: Delete data | InfluxDB Cloud Serverless Documentation
But this page suggests its possible via the cli: influx delete | InfluxDB Cloud Serverless Documentation but contains a broken link to what the “influxql like predicate” statement looks like.

It seems its not supported, I tried to delete some data without a predicate statement and although the cli (v2.7.3) didn’t return an error, the data is still there.

My use case is that a wrong data type has been sent to a new measurement and subsequent ingests are failing. It would be much easier for me to delete the offending data than have to set up a new measurement and change everything to use that instead.


1 Like

+1, same question here!
Was anybody able to sort that out?


I seem to have the same problem. @kleptine did you figure it out how to delete?