Access denied when running pythonClient from linux, but ok when running from windows

client-libraries
influxdb
#1

hi,
i have this simple script using the influxdb python agent:
from influxdb import InfluxDBClient
from influxdb import SeriesHelper

targetHost = '10.242.52.146'
port = 8086
user = ''
password = ''
dbname = 'Data'
measurementName = "SIS"

client = InfluxDBClient(targetHost , port, user, password, target_dbname)
queryString = "SELECT * FROM \"SIS\" where time > '{0}' and time < '{1}'".format(endQueryTime,startQueryTime)
points = client.query(queryString, database=dbname, chunked=True)

when i run this on windows runs perfect,
but when i run on centos 7 i get this error :

Traceback (most recent call last):
  File "DB_Generator-allDataBulk.py", line 38, in <module>
    points = client.query(queryString, database=dbname, chunked=True)
  File "/usr/lib/python2.7/site-packages/influxdb/client.py", line 409, in query
    expected_response_code=expected_response_code
  File "/usr/lib/python2.7/site-packages/influxdb/client.py", line 286, in request
    raise InfluxDBClientError(response.content, response.status_code)
influxdb.exceptions.InfluxDBClientError: 403: <HEAD><TITLE>Access Denied</TITLE></HEAD>
<BODY BGCOLOR="white" FGCOLOR="black"><H1>Access Denied</H1><HR>
<FONT FACE="Helvetica,Arial"><B>
Description: You are not allowed to access the document at location <em><TEXTAREA READONLY rows="2" cols="75">http://10.232.252.93:8086/query?q=SELECT+%2A+FROM+%22SIS%22+WHERE time+%3E+%272017-12-26+16%3A02%3A24%27+and+time+%3C+%272017-12-26+16%3A03%3A24%27%29&amp;chunked=true&amp;db=Airtel_Data</TEXTAREA></em></B></FONT>
<HR>
<!-- default "Access Denied" response (403) -->
</BODY>

any ideas ?
i suspect it might have something to do with the user and password being blank, mybe linux doesnt know how to handle this?

thanks.