Windows CPU Measurement - Missing cpu tag

#1

I’m using the nightly build for v1.3 (http://52.216.226.91/dl.influxdata.com/telegraf/nightlies/telegraf-nightly_windows_amd64.zip).

The cpu input is not collecting for multiple cpus. The Windows VM reports there are four cpus. A measurement record is reported but the cpu tag is missing. I would expect to see “cpu = cpu” - one for each cpu.

I tried to force a record by adding a custom tag (cpu = “cpu0”) to the input; however, it was not sent. I also tried to add it as a global tag - it was removed. If I call it something else, it shows up, e.g. mycpu = “cpu0”.

This works as expected on Linux. Anyone using this on Windows?

[[inputs.cpu]]
# Whether to report per-cpu stats or not
percpu = true

# Whether to report total system cpu stats or not
totalcpu = false

# If true, collect raw CPU time metrics.
collect_cpu_time = true

# do not send these fields in the message - collectd DB is only interested in raw time
fielddrop = ["usage_*", "*_min", "*_max", "time_guest", "time_guest_nice"]

# Don't collect total cpu values
[inputs.cpu.tagdrop]
cpu = ["cpu-total"]

#[inputs.cpu.tags]
#cpu = "cpu0"
#2

@hcrocker There is a win_perf_counters plugin that is designed to collect windows system metrics. Have you tried that?