Weird measurements in InfluxDB bucket

Hey guys,

I am new to InfluxDB and Telegraf so I am a bit overwhelmed by everything.
I have a window sensor that is using zigbee to communicate.
Furthermore I have an Zigbee2MQTT Docker container that pushes the messages pushed by the sensor into a topic (homeassistant/rooms/bedroom/window).
I use an MQTT which is also running in a docker container.
Communcation between thos two is okay as I can subscribe to homeassistant/rooms/# and see the message once I close the window contact.

Now I want to use Telegraf to get the messages into InfluxDB. The sensor sends more data than I need so I want to parse it.
Telegraf is configured to listen to homeassistant/rooms/#
Everything seems to work fine as the measurement is correctly parsed and added to my homeassistant bucket with the correct measurement name.

However as I tried to get my hands on the data explorer of my DB (which is also running in a container) I saw many, many measurements. I tried to get a list of them but I did not get it to work with influx cli (I did not even get to get a list of my buckets as I always got an empty list but thats another problem.

Here is a example list of measurements I have in my bucket:

  • bedroom (which is the measurement I want to have, with field isWindowClosed)
  • boltdb_reads_total
  • boltdb_writes_total
  • go_gc_duration_seconds
  • go_info
  • go_memstats_frees_total
  • a lot more go_memstats
  • http_api_requests_total (and many more http related measurements)
  • influxdb_info
  • influxdb_remotes_total (many more influx related measurements)
  • qc_all_active (and many more qc related measurements)
  • service_bucket_new_call_total (many more service related measurements)
  • storage_user_new_duration (many more storage related measurements)
  • task_scheduler_execute_delta (and some more task related)

I tried to get behind all these but I do not even know where to start.
Is this a Telegraf problem or did I misconfigure something else?

I hope someone could explain to me what is going on.

Thanks in advance,


Stupid error: Did not get that the measurments of influx are automatically written into the first created bucket if I choose get started on initialization