W! Skipping a scheduled flush because there is already a flush ongoing


Jan 09 17:36:58 server1 telegraf[1606]: 2018-01-09T16:36:58Z W! Skipping a scheduled flush because there is already a flush ongoing.

–==Central server==–

–==VMs side==–

Configuration of Telegraf: /etc/telegraf/telegraf.conf
interval = "15s"
round_interval = true
metric_batch_size = 1000
metric_buffer_limit = 10000
collection_jitter = "0s"
flush_interval = "15s"
flush_jitter = "15s"
precision = ""
debug = false
quiet = false
hostname = “”
#logfile = "/var/log/telegraf/telegraf.log"
omit_hostname = false

I’ve read about: interval, flush_interval, flush_jitter recommendation and the things looks like:
Telegraf has a few options you can configure under the [agent] section of the config.
interval: Default data collection interval for all inputs
flush_interval: Default data flushing interval for all outputs. You should not set this below interval. Maximum flush_interval will be flush_interval + flush_jitter
flush_jitter: Jitter the flush interval by a random amount. This is primarily to avoid large write spikes for users running a large number of telegraf instances. ie, a jitter of 5s and flush_interval 10s means flushes will happen every 10-15s.

***In the past I had different values interval: 10s | flush_interval: 10s | flush_jitter: 0s with no problem, now I’m thinking about to change the flush_jitter from 15 to 5s.

Any recommendation?

Kind Regards,

I would recommend setting these settings so that the flush_jitter + max amount of time it normally takes to flush < flush_interval. If your only output is InfluxDB, then 5s would work great, and I would definitely keep it under 10s.

1 Like

Great, thank you for your valuable support.
The only output is InfluxDB in my case.

Kind Regards,