Skipping a scheduled flush because there is already a flush ongoing

#1

Hi

am seeing these messages very frequently. what could be the reason?

[skotaru@cae-ga1-1 hosting]$ oc logs -f telegraf-agent-s86r1
2017/06/22 09:35:04 I! Using config file: /etc/telegraf/telegraf.conf
2017-06-22T09:35:04Z I! Starting Telegraf (version 1.3.0)
2017-06-22T09:35:04Z I! Loaded outputs: influxdb influxdb
2017-06-22T09:35:04Z I! Loaded inputs: inputs.cpu inputs.mem inputs.docker inputs.swap inputs.system inputs.net inputs.netstat inputs.disk inputs.diskio inputs.kernel inputs.processes inputs.procstat inputs.procstat inputs.procstat
2017-06-22T09:35:04Z I! Agent Config: Interval:1m0s, Quiet:false, Hostname:"", Flush Interval:10s
2017-06-22T22:06:20Z W! Skipping a scheduled flush because there is already a flush ongoing.
2017-06-23T04:04:20Z W! Skipping a scheduled flush because there is already a flush ongoing.
2017-06-23T09:23:10Z W! Skipping a scheduled flush because there is already a flush ongoing.
2017-06-23T18:21:20Z W! Skipping a scheduled flush because there is already a flush ongoing.
2017-06-25T14:43:10Z W! Skipping a scheduled flush because there is already a flush ongoing.
2017-06-27T17:52:10Z W! Skipping a scheduled flush because there is already a flush ongoing.

agent configuration

[agent]
interval = "60s"
round_interval = true
metric_batch_size = 1000
metric_buffer_limit = 10000
collection_jitter = "5s"
flush_interval = "10s"
flush_jitter = "5s"
precision = ""
debug = false
quiet = false
logfile = ""
hostname = ""
omit_hostname = true

#2

@Srinivas_Kotaru Have you tried changing your flush_interval to 60s? I think that would make these errors go away.

#3

@jackzampolin Today I pushed the change. I will closely watch … Can u confirm jitter setting is ok. it is curretnly configured to 5 seconds

#4

@Srinivas_Kotaru Thats fine. It will vary the timing of your flushes by +/- 5s.

#5

Something similar and it will be great if you can take a look below for the config.
Any suggestions here will be kindly appreciated.

  • Message:
    Jan 09 17:36:58 server1 telegraf[1606]: 2018-01-09T16:36:58Z W! Skipping a scheduled flush because there is already a flush ongoing.

–==Central server==–
grafana-4.6.3-1.x86_64
influxdb-1.4.2-1.x86_64
telegraf-1.5.0-1.x86_64

–==VMs side==–
telegraf-1.5.0-1.x86_64

  • Configuration of Telegraf: /etc/telegraf/telegraf.conf
    [agent]
    interval = "15s"
    round_interval = true
    metric_batch_size = 1000
    metric_buffer_limit = 10000
    collection_jitter = "0s"
    flush_interval = "15s"
    flush_jitter = "15s"
    precision = ""
    debug = false
    quiet = false
    hostname = “”
    #logfile = "/var/log/telegraf/telegraf.log"
    omit_hostname = false

I’ve read about: interval, flush_interval, flush_jitter recommendation.

Kind Regards,

#6

Hi,
I think flush_jitter is too high. Recommendation is: flush_jitter + amount of time to send to output < flush_interval. I suggest to set a lower flush_jitter.
regards

2 Likes
#8

Like:
interval = “10s”
flush_interval = “16s”
flush_jitter = “5s”

#9

Yes, this would be a good example. Thanks for it!

1 Like