Use InfluxDB in an isolated place

My problem is to use Influxdb in an isolated (internet free) place which is my boat 6 miles out on the see.

I tried it on a local wifi network without connected to the internet and it does not seem to work.

MQTT and Node Red works well on my Intranet but I still could not get Influxdb working.

I get to the xxx.xxx.xx.x:8086 URL but after entering user and password nothing happens.

When I connect to the Internet everything is fine.

I know it is Cloud based but I have been told that 2.0 can be used on Local WiFi network.

What should I do to fix this?

As far as I know, there isn’t anything in InfluxDB that requires a connection to a public network except for telemetry reporting (“phone home”) which just reports information about your local instance back to InfluxData. To disable this functionality, just add the --reporting-disabled flag when you start influxd:

influxd --reporting-disabled

If this doesn’t work, this is definitely a head scratcher that will require some more digging. If this does fix it, it’s also something that should be reported as a bug.

1 Like