Getting started (LocalHost problem)

Hi! I’ve just started using Influx and I’m completely new to databases.
I have a database I need to open with the OSS version of Influx.
I have followed this guide https://v2.docs.influxdata.com/v2.0/get-started/
I have successfully installed Influx, but I can’t set it up.
In particular, I can’t access to Local Host: it keeps giving me the “404 error”.
How am I supposed to use the OSS version of Influx’

Give us enough information to reproduce your situtation and problem, then we
might be able to help.

For example, tell us:

  1. What operating system and version are you installing InfluxDB on?

  2. Which of the instructions on the page you linked to did you follow in order
    to install InfluxDB?

  3. You say you “successfully installed” InfluxDB - how do you know that it was
    successful - what did you test in order to be sure?

  4. When you “can’t access to Local Host” (the way you write localhost concerns
    me about you familiarity with networks), how are you trying to access it
    (Command line? Browser? What exactly are you doing)?

  5. Have you done any independent check to make sure that InfluxDB is actually
    running on your machine (depending on what systems you installed on, this
    might involve “ps ax” or “netstat -lptn” etc.)?

Finally, you do realise that InfluxDB 2.0 is a beta release? Any reason you
haven’t started out with the current stable release 1.7?

Antony.

  1. I’m using macOS Mojave, version 10.14.6
  2. I followed “Start with InfluxDB OSS”: I downloaded the file, unpackaged it, and started it with the command “influxd” on my terminal. Then, as I tried to access to LocalHost as written in the guide, it keeps telling me that “the server is occupied” or the “404 error”.
  3. I think I successfully installed Influx since as I run the command “influx” on the terminal this happens:
  4. I’ve tried connecting to the many links I’ve found: the first is the one in the guide, “http://localhost:9999” and the error is: Safari can’t connect to the server; Safari can’t open the page localhost:9999 because it can’t connect to the server “localhost”.
    Then I’ve tried opening the link I’ve found on the terminal, that is “http://127.0.0.1:8088” but this time the error is: Safari can’t open the page 127.0.0.1:8088 because the server has unexpectedly interrupted the connection, that sometimes happens when the server is busy. Wait a few minutes and retry.
    Of course I’ve tried many times and the error is always the same.
  5. I don’t know how to run independent checks, as I’ve said I’m completely new to all this stuff.
    Moreover, I am actually using the stable release 1.7.9, that I have downloaded from the guide link. I see also that a 1.8.0 version exists, and I’m upgrading the one I’ve already have.
    Thank you for your quick reply.

I will say that I am also completely new at this. I just heard about InfluxDB on Thursday of last week. In the last few days I have installed the entire stack about a dozen times trying to get different things to work. I have used Ubuntu and CentOS, but I have to say that all of the InfluxDB stuff that I have done has been command line and that seems to be working.

As for your problem, do you have anything else running that is already listening on those ports? What are you trying to accomplish as the end goal? You shouldn’t need a GUI for the database too much. My problem was trying to configure Telegraf correctly to feed the Influx database.

Good luck

If i recall correctly, there is no web interface for Influx 1.X it was removed in version 1.3 and replaced with the Chronograf package. You can query, manage and visualise your data from there. I usually manage my databases from the Influx CLI though.

I don’t think the documentation you followed applies to the version you are running.

This is for 1.8 but should still apply to 1.7

set up

For what I see, you are getting an error on point 3.
It clearly says that the bind address is already in use (127.0.0.1:8088), therefore you will need to disable whatever is currently using that port, or better just use a different one for InfluxDB.

In the influxdb configuration file there is a parameter to set the bind address, by default it should be port 8086, just change it to a different one

  {...}

[HTTP]

  {...}
  # The bind address used by the HTTP service.
  bind-address = ":8086"
  {...}

You will probably need to change other configurations or pass additional parameters in other tools (ie the influxdb cli) since they usually look for influxdb on its default port,

Dear Antony,
I have a similar problem with running influxdb. Firstly, I am quite new with this timeseries software. I wish to get data from Iot sensors(LoRa Gateway) using Influxdb integration and then create dashboards for this. But,I am unable to get influxdb to listen to my data.

  1. I am using Windows 10. Ihave downloaded Influxdb 1.7.6.
  2. I didn’t have much support on this page for windows installation. I followed instructions from this link https://devconnected.com/how-to-install-influxdb-on-windows-in-2019/#comment-8381
  3. I am trying to connect to local host in browser using 8083, 8088.
    As far as it gets, I was unsuccessful. Also, could you probably know how to input data from Influxdb integration to run on Influx cloud?