Installing InfluxDB for Windows

I’m having trouble installing Influx for Windows, i tried running it using Go but still doesnt work for my pc.

By any chance someone can provide a tutorial on how to install it??

Please bear in mind that Windows support for InfluxDB is considered experimental:

CaptureThis is what I’m getting after I run the influxd file and then the local host wont connect, any advice please?


It seems the port you are trying to bind your influxdb instance to is already in use. (is another instance of influxdb already running in the background or as a service?)

Edit your config and change port 8088 to another then try again.

I think there is an InfluxDB instance at the services but it is not running the moment im trying to run Influxd and now it keeps sending this error "No connection could be made because the target machine actively refused it. and it is referring to the localhost:9092 when in configuration file i have 8088.

Im very confused as to how i can get InfluxDB up and running, i could really use some help.

Thank you in advance

Would using Docker work for your use case? Or do you need to have the database installed on Windows?

In the TICK stack universe, localhost:9092 would normally be where you would have Kapacitor running.

I’d shut all the TICK stack processes down and see if any other processes are running on 8088 first.

Also, it looks like you are trying to run a nightly? (1.7.0 isn’t GA). Grab a GA build from:

Im trying to run the Tick Stack but it is not working for me as the command line cant find any browser in the pc and also it just cant connect to the localhost server in the browser.

can you please help because im pretty confused on how store data through java application, and I’m running Influx and all its components one by one in command line

You’re not providing enough information for us to help troubleshoot. The more details you include about what you’ve already tried, the errors your seeing, and your particular configuration, the better we’ll be able to assist you.

How are you installing InfluxDB? Where are you installing it to?
In your screenshot, InfluxDB is using port 8088. Why are you changing the configuration to use port 8088?
What does “the command line cant find any browser in the pc” mean?
Can you connect to InfluxDB using the CLI?
What do you mean by “it cant connect to the localhost server in the browser”? localhost is a hostname that refers to the computer. If you try connecting to localhost from the browser, it will send you to the default port for HTTP, port 80. None of the components of the TICK stack use this port. When you run Chronograf, it runs on port 8888, so you can connect to it from the same computer using http://localhost:8888.

Did you follow the instructions in the blog post? At what step did you run into issues?

Okay so apparently there was a previous install of InfluxDB in my engine, tried deleting all the files but couldnt delete it, then im trying to run each component on its own, kapacitor, influx, telegraf, influxd, chronograf and then i can access the localhost:8888.
Tried as shown in the example: Running the TICK Stack on Windows | InfluxData
Im using the default configuration but i tried many other ways since it wasnt working.

When you call ./sandbox up it load everything and is ready to launch, but if i was running cmd in administrator it would open the links in browser but could not connect to them, “localhost refused to connect”.
If im just running a simple docker and running sandbox up, then it loads as in the screenshot that i attached.

Now when starting each component on its own cmd, i can go to localhost:8888 and i can use chronograf but it is kind of limited as i do not have a host lists.

Im new to this and im trying to learn more and fast on how i can send data to my InfluxDB from my Java application so if you have any advice or articles that can help me through this would be perfect.

Thank you for your help!

In case anyone has the same issue (like I did), you may have mistakenly run the influx.exe before following the instructions mentioned in the first reply on this thread. It could also be you already have another process running at 8086.

To find if a process is running at port 8086, open a cmd.exe prompt and type:
netstat -ano | findstr : 8086

You’ll see if there are any processes bound to the port in a list, and the last column will show its process ID (PID) ex. 16084

If you’d like to kill it (and are sure it’s a process you created by mistake) open an admin cmd.exe prompt and type, with the PID prev. identified and no quotes:
taskkill /PID "typeyourPIDhere" /F

You should now be able to run influxd.exe via cmd.exe and get past the “Only one usage of each socket address…” issue.

Note: I did try to set up the influx.conf to use another port, but it didn’t seem to take, in case anyone else wants to respond to that as another option; especially if you can’t kill a process you prev. bound to port 8086.

Hi team,
I am trying to install influx on my system. I have downloaded that from downloads where version v1.7 is the latest version it seems like, Downloads

After getting that in my system inside the program files ran the file influxd.exe. Its now showing the below screen

Now after that i ran http://localhost:8086/ but it’s showing the file not found in browser.

can you help me guiding here if I am missing any step or making mistake here


Hi are you trying to connect to the database ? You can do that with the commandline interface by running : influx for example.

When you say its experimental. The downloadable is there for windows, and it doesnt say its experimental on the front page, and its there for 1.7.6, and yet the instructions on the general Influx website, bear no correspondence it appears to a windows install.

I actually think it would be fairer for someone arriving at your website, that it says on the website download page, that windows is experimental, and that the instructions are specific and elsewhere than the getting started. It would be quite natural for anyone to give it a shot on their PC first prior to getting a linux server setup, and the way it is now, is a bit disrespectful of our time, because each of us trying this is going to waste an hour or two trying to get it setup on windows prior to looking to figure out what is wrong under community or blog.