Unable to log into command line on new install

I’ve just downloaded and installed the Windows version of InfluxDB v2.2.0. It’s up an running, and I can access it via the Web UI. However, I’m unable to connect to it via the command client.

The command client is Influx version CLI 2.3.0 (git: 88ba346) build_date: 2022-04-06T19:30:53Z.

For example, if I run “influx”, it returns a list of commands:

influx - Influx Client

influx [command]

version Print the influx CLI version
write Write points to InfluxDB
bucket Bucket management commands
completion Generates completion scripts
query Execute a Flux query
config Config management commands
org, organization Organization management commands
delete Delete points from InfluxDB
user User management commands
task Task management commands
telegrafs List Telegraf configuration(s). Subcommands manage Telegraf configurations.
dashboards List Dashboard(s).
export Export existing resources as a template
secret Secret management commands
v1 InfluxDB v1 management commands
auth, authorization Authorization management commands
apply Apply a template to manage resources
stacks List stack(s) and associated templates. Subcommands manage stacks.
template Summarize the provided template
bucket-schema Bucket schema management commands
ping Check the InfluxDB /health endpoint
setup Setup instance with initial user, org, bucket
backup Backup database
restore Restores a backup directory to InfluxDB
remote Remote connection management commands
replication Replication stream management commands
server-config Display server config
help, h Shows a list of commands or help for one command

–help, -h show help

If I run:

influx --org example-org --token mySuP3rS3cr3tT0keN

it returns:

Incorrect Usage. flag provided but not defined: -org

If I run

influx config list

It actually works:

Active Name URL Org

  •   default http://localhost:8086   example-org

But I would like to get into the client to run the InfluxSQL command.

And ideas?

Hi @Jack999,
The InfluxDB CLI currently does not have access to the previous interactive shall from 1.X. This will change in an upcoming release of the CLI where we have added the shell back in. In the meantime i would check out this documentation to run influxql commands: Query data with InfluxQL | InfluxDB OSS 2.3 Documentation