Telegraf SNMP Gauge32 [Solved]

I’m reading some Gauge32 values through SNMP with telegraf. I’m not able to use these values in Grafana. I’ve tried to convert them to integers, but it doesn’t seem to be working. Output from telegraf is:

measurementName,agent_host=,host=server,hostname=hostname,ifAlias=nexthop,ifName=ethernet1/2/2,memUsedPercent=27 ifInOctets=328333007380i,ifOutOctets=2534633191696i 1539978582000000000

memUsedPercent is a Gauge32 type when read from SNMP, but doesn’t have the “i” at the end, like the in and out octets.

In the config file for telegraf I have the following:

 name = "memUsedPercent"
 oid = "<oid>"
 is_tag = true
conversion = "int"

Taking out the conversion line doesn’t make a difference. Is there a way to be able to use the Gauge32 values in Grafana since it doesn’t think they are integers? I’ve also tried conversion to float and that doesn’t appear to be working either.

Ok, today’s been a fun day. :angry:

Thanks to copy/paste, I still had is_tag = true in there. I’ve googled for like 2 hours before posting here. And then 5 minutes later realize what I had done. Take out the is_tag and it converts to integer just fine.

1 Like