Telegraf ignoring seconds precision and inserts wrong timestamp

Using telegraf with http_listener_v2 plugin for input and influxdb plugin for output.

Posting data in line control format and timestamp with seconds precision. This data is getting inserted to influxdb with wrong timestamp.
Tried setting [agent].precision = “1s” but didn’t help.

Input: process_count,process_name=Proc33 pcount=197 1568270854
InfluxDB: “1970-01-01T00:00:01.568270854Z”, “Proc33”, 3673

You must use the influxdb_listener to sending line protocol that is not using nanoseconds for the timestamp, it takes the same precision query parameter as InfluxDB:

curl -X POST "http://localhost:9999/write?precision=s" -d 'process_count,process_name=Proc33 pcount=197 1568270854'

Okay… Thanks Daniel.