Telegraf config keeps giving me parse error that I cannot resolve


For the last couple of weeks I have been trying to set up a docker TIG stack with telegraf, influxdb and grafana. And though I have had many struggles with various things, right now I am stuck at a telegraf config, that I cannot for the life of me, figure out why it has a parse error.

I am using a socket listen input for catching JSON messages from Windows servers.

When I look at the logs of the telegraf service, all it gives me is that I got an error on a line, which does not contain anything anymore. It used to contain a keep_alive_period = "60s". I removed the line, but it still gives me errors on that empty line.

Any help is appreciated, thank you!

Try commenting out like 25, read_buffersize and then restart Telegraf. I am curious if the line number in the error message changes.

If commenting it out resolves the error, then you have a formatting issue on that line

I commented out line 25 and moved things a bit around, got some new lines that were problematic, which i did get fixed.

I managed to get a socket error when commenting out most of the conf for the listening socket, but adding them back in just showed the same result

I also tried commenting out all of the json parts, but still no avail

You need to quote this option since it is a string and fix the option name:

read_buffer_size = "64KiB"

I also see you are missing a comma in the tag_keys option, make sure to have one after each value.