Tasks - Cron Offset

Per documentation:


Delays the execution of the task but preserves the original time range. For example, if a task is to run on the hour, a 10m offset will delay it to 10 minutes after the hour, but all time ranges defined in the task are relative to the specified execution time.

This does not appear to be the case; with the following I get times that are one minute after the hour:
option task = {name: "task-Hourly", cron: "0 * * * *", offset: 1m}

Is there a workaround for this, or am I missing something? I need my data windowed relative to the hour, but I have to run multiple tasks on the data some hours of the day.

Hello @Patrick808,
How are you querying your data?
Also can you use the every option instead?
So that you can query your data with range(start: -task.every)?