[solved] Grafana + Influx: graphs 1 hour off

#1

Hello,
I have Grafana graphing influxDB data. I’m not sure where the issue is, but when I push data into influx, and graph it with Grafana, the data is 1 hour behind. I’m running this on a Raspberry Pi, and the system time and time zone is correct.

Below, the interval is now to now-3hours. I’m pushing that data just now, so it should be all the way on the right side of the graph. Instead, it’s showing up 1 hour in the past. I have no overrides in the Time Range tab, and no time shifts. The correct behavior should be new data showing up all the way on the right.

I don’t have any time shifts or overrides. So any now to now-time should show the latest data on the right. Instead, the data seems to be graphed 1 hour in the past.

#2

How are you collecting this data?

Can you share the output from the date command on your RPi and confirm that it is what you expect to see?

#3

Well, I thought I found the problem, but I actually haven’t.

Here’s the result of “timedatectl status” on a system.

Working System’s response:

Local time: Mon 2018-04-30 21:50:59 CDT
Universal time: Tue 2018-05-01 02:50:59 UTC
RTC time: n/a
Time zone: America/Chicago (CDT, -0500)
Network time on: yes
NTP synchronized: yes
RTC in local TZ: no

The date/time is correct for my timezone. “date” command returns correct date.

One thing to note: Using the exact same microSD card, I was able to have correctly plotted graphs at a local college on a different raspberry pi. Taking that microSD card and putting into my own Pi’s, I get this 1 hour issue. I’ve tried it on two raspberry pi (Pi3B+ and Pi3), and both have the same issue (at least at my home network). The thing in common is that they’re both in my home network. I’m unable to take the Pi from the college home to try it in my network to see if the problem follows the network or the Pi. I suspect it’s my network, but I don’t see how. The “date” command as well as the “timedatectl status” returns correct time.

#4

I found the issue. The computer browsing Grafana had the wrong time zone set.

#5

Great, glad you got to the bottom of it. Time Zones are notoriously problematic.

closed #6