Query-timeout configuration param doesn't work


#1

In short using influxdb 1.7.2 where I have set following query limits:
log-queries-after = “60s”
query-timeout = “120s”

Now after running large query (from influx cli) following occurs:
ts=2019-02-25T04:09:09.400134Z lvl=warn msg=“Detected slow query: SELECT * FROM WHERE id = LIMIT 1 (qid: 123456789, database: , threshold: 1m0s)” log_id= service=query

However query-timeout is never triggered (which I would assume happening after 2min) and in the end influx query eats all memory, system swaps and 10min from there OOM occurs.


#2

Just to check–have you restarted the Influx service since you made changes to the config?


#3

Yes I have done restart after config change


#4

Hi can you share the output of :

influxd config|grep -i quer


#5

docker exec -i -t influxdb /usr/bin/influxd config|grep -i quer
query-log-enabled = true
max-concurrent-queries = 0
query-timeout = “2m0s”
log-queries-after = “1m0s”
[continuous_queries]
query-stats-enabled = false