Problems with restore db

yesterday I made backup of my influxdb by:

influxd backup -portable /path/to/backup-destination

Then I changed my OS on rpi4 to 64bit OS and installed influxdb back. same version.

InfluxDB v1.8.10 (git: 1.8 688e697c51fd)

And now I wanted to restore this data, and I get everytime same error:

openhabian@openhabian:~ $ influxd restore -portable -database openhab_db -newdb openhab_tmp_db /home/openhabian/inf
2022/10/24 19:13:53 Restoring shard 180 live from backup 20221023T180612Z.s180.tar.gz
2022/10/24 19:13:53 Restoring shard 84 live from backup 20221023T180612Z.s84.tar.gz
2022/10/24 19:13:54 Restoring shard 172 live from backup 20221023T180612Z.s172.tar.gz
2022/10/24 19:13:55 Restoring shard 233 live from backup 20221023T180612Z.s233.tar.gz
2022/10/24 19:13:56 Restoring shard 253 live from backup 20221023T180612Z.s253.tar.gz
2022/10/24 19:13:56 Restoring shard 258 live from backup 20221023T180612Z.s258.tar.gz
2022/10/24 19:13:57 Restoring shard 261 live from backup 20221023T180612Z.s261.tar.gz
2022/10/24 19:13:58 Restoring shard 299 live from backup 20221023T180612Z.s299.tar.gz
2022/10/24 19:13:58 Restoring shard 212 live from backup 20221023T180612Z.s212.tar.gz
2022/10/24 19:13:59 Restoring shard 217 live from backup 20221023T180612Z.s217.tar.gz
2022/10/24 19:14:00 Restoring shard 229 live from backup 20221023T180612Z.s229.tar.gz
2022/10/24 19:14:00 Restoring shard 251 live from backup 20221023T180612Z.s251.tar.gz
2022/10/24 19:14:01 Restoring shard 254 live from backup 20221023T180612Z.s254.tar.gz
2022/10/24 19:14:02 Restoring shard 36 live from backup 20221023T180612Z.s36.tar.gz
2022/10/24 19:14:03 Restoring shard 226 live from backup 20221023T180612Z.s226.tar.gz
2022/10/24 19:14:03 Restoring shard 218 live from backup 20221023T180612Z.s218.tar.gz
2022/10/24 19:14:04 Restoring shard 236 live from backup 20221023T180612Z.s236.tar.gz
2022/10/24 19:14:04 error updating shards: write tcp> write: connection reset by peer
restore: write tcp> write: connection reset by peer

First I tried to restore it by this function:

influxd restore -portable /path/to/backup-destination

but got same errors. Then I started new db and wanted to restore data to other db and merge it, but still get same errors.

Can someone please help me restore this data?

Hello @matulekpl,
What version of Influx are you using?
Could it be related to: influxd backup only states "connection reset by peer" · Issue #13706 · influxdata/influxdb · GitHub