Package join not exist

OS: Windows 11 Home Edition
Docker Desktop: 20.17.11 with WSL2 enabled
InfluxDB Version 2.4.0 running on docker container.
Image used: Docker

Telegraf version 1.24.0 running on docker container.
Image used: Docker

Hi guys, Thanks for helping.
Today i have a strange issue while trying to join 2 tables.

According to official docs, you can import join package.

import "join"

But that thing does not work, it said

invalid import path "join"

Don’t know why… And i need some help!
There is a join() function exist, but v2.4.0 docs never mention about that.
Why this happen? Is this just my issue or this happens to everyone?

Thanks for helping beginner

Hello @heechan_Lee,
That’s super strange. Is the import statement at the top of your script?
Let’s see the Flux version is:

update flux to v0.172.0
Usually the docs show which version of flux is required for each function. But that’s missing from the join functions.

Oh I see thats reference docs. The function docs include it:

Hmm I’m confused. I’m asking around.

1 Like

Hi, Thanks for answer!
I checked my Flux version and it seems my Flux version is something v0.172.0 below thingy. My server is “de247ba” .

I’ll try to update Flux Version.

Hi, Anaisdg? I tested newer version of influxdb 2.4.0 OSS docker image and i finally made it. The join package succesfully imported and worked!

However, there is a minor bug in UI feature.


This said that my code has a bug, but it worked without error. :<

And my Flux Version is v0.179.0.

My Docker image digest is this → Docker

Anyway, my main problem just got solved and thanks for help.

1 Like

Hello @heechan_Lee,
I’m glad that it worked.
Hmm I’m not sure why that error exits. Thank you for sharing though.

@Anaisdg Hello, I am a beginner. I am using influxdb 1.8.3 and Grafana 9.2.3. I am trying to use inner join to join two flux queries, and encounter “Unknown import path: ‘join’”. I have no idea how to check my flux version. Don’t know how to solve it. I watched your videos, which are very helpful for me to create the queries. I need to get import packages work because I need to import them. By any chance, could you please help? My InfluxDB and Grafana are running on the same Ubuntu 20 VM without docker. Thanks!