Out of memory while Retention Policy runs

Hi all,

I have encountered very weird problem with InfluxDB :frowning:
Once Retention Policy starts it breaks the instance with error: out of memory. I have tried on both t2.medium (4GB) and t2.large (8GB) in AWS. Influx is in docker

Additionaly I have setup also new database and tried to remove shards manually by DROP SHARDS and effect was the same after removing few shards - also getting info about out of memory.

I checked couple of posts already about the problem, eg. https://github.com/influxdata/influxdb/issues/38 and the problem with high memory (unlimited) consumption seems to be real.

Few additional data needed:

  • shard groups duration - 7d

Hi @robert.grzeskowiak,

Can you please provide a heap profile from your instance when it begins the costume too much memory, please?

Unfortunately, these problems are very difficult to debug and we can’t really do much without the profile.

https://docs.influxdata.com/influxdb/v1.8/tools/api/#debug-pprof-http-endpoint

Hi @rawkode

I dumped heap profile. Just wanted to attach it, unfortunately got the info that as a new community user I cannot add attachments. Please find it on google drive: https://drive.google.com/file/d/1mLt25im1CgwfQbH3ozYzh5RM-T9vI3E8/view?usp=sharing

Hi,

I have downgraded inflxudb from 1.8.0 to 1.5.4 and it works like a charm in older version. Looks like a bug in newest release.