No new measurement after insert data or "show measurements" didn't show all measurement

I try to list all measurements with the command “SHOW MEASUREMENTS” and discover that not all measurement are listed.
In my case, I have 2 devices: device_da and deivce_wc.
With device_da, I can get tag keys, data point and I can see data_da with ‘show measurements’.
With device_wc, I can still get data point but the tag keys and ‘show measurements’ return only data_da.
I try with PHP and python language and get the same results.
Please help me figure out what’s going on.

Hi @jimy811111 ,

how is the data loaded in the database ? Using telegraf ?
How do you get the datapoints ? Can you share the queries used ?

best regards ,

@MarcV
Thanks for your reply. Following is my request and response.


I have several device types and only device_wcs cannot show in the ‘show measurements’ while I can still get the data with ‘select * from…’.

Hi @jimy811111,
Can you do a show measurements using the command line : influx ,

Best regards

@MarcV
I query the influx via the command line for the first time. Hope I’ve done right.

Thanks for your reply.

Hi @jimy811111 ,

you have done right ,

I tried to reproduce this on a testdabatase 1.7.4 , but there I don’t have that problem …
what is your version ?

@MarcV
Mine is 1.7.0. and I don’t know what cause this problem. I use the same code in Laravel to insert the first point of each measurement.

@jimy811111 ,

do you have plans to upgrade to 1.7.6 ?
In this document I see that there is a bug fixed concerning measurements in 1.7.2 …

https://docs.influxdata.com/influxdb/v1.7/about_the_project/releasenotes-changelog/

Checks if measurement was removed from index, and if it was, then cleans up out of fields index. Also fix cleanup issue where only prefix was checked when matching measurements like “m1” and “m10”.

@MarcV
Thanks for your help. I also found the note after you mention the version above. But due to my limited understanding of InfluxDB, I don’t know if this is the reason. I will report that to my manager and if I can upgrade the influxDB, I’ll update the situation.

@MarcV
Situation Update. It works!
After upgrading to version 1.7.6 and restarting InfluxDB, ‘SHOW MEASUREMENTS’ do show all measurements. Thanks you very much!

1 Like

Thanks for the feedback Jimy !! Good to hear it works now.

1 Like