No kapacitor messages sent to Alerta


New to Influx and Kapacitor!
I have made a tick script and can see it fire critical alerts using kapacitor show.
I have attempted to setup alerta reporting.
In the kapacitor config file I changed the default alerta config to enabled and added the IP of the alerta VM to the url item. Restart kapacitor after config change.
My tick script alert section looks like this :
.id(’{{ .Name }}/{{ index .Tags “OceanRegion” }}’)
.message(’{{ .ID }} is {{ .Level }} LAUs-pr-minute :{{ index .Fields “GoodLAUs”}}’)
.crit(lambda: “GoodLAUs” < 1200.0)
.resource(‘Hostname or service’)
.event(‘Something went wrong’)

When kapacitor fires critical alerts no packets are sent to alerta. I have checked with wireshark (on the kapacitor VM) and see nothing at all to the alerta IP.

What is missing ?


@Lasse Do you see anything in the log about POST requests to Alerta?


No, nothing in the kapacitor log either. I can see the critical alert count up when I run kapacitor show.
kapacitor version 1.2.0.


@Lasse can you post the Alerta section of your configuration file as well?

kapacitor config for alerta :

Configure Alerta.

enabled = true

The Alerta URL.

url = “

Default authentication token.

token = “”

Default environment.

environment = “Production”

Default origin.

origin = “kapacitor”

@Lasse is the anything about Alerta in the logs? Have you restarted kapacitord since you made those changes? Do you see Starting Alerta Service... or something like that?


I had two instances of kapacitor running.
Once I shut them both down and started a new instance it worked.
Many thanks for your help.


1 Like