New to Influx: Test CSV Upload succes, but not measurments in Bucket

I am new to Influxdb cloud and I just wanted to do a first test to upload data via csv file. I found a csv file via the Git repository of Anaisdg, which finally worked from the annotations (bitcoin-historical-annotated.csv) and was able to upload it successfully. But no measurments are found in the relevant bucket, even if I select the correct time filter.

Can anybode point me to the right direction?

Another question would be if there are tutorials somewhere on how to get Telegraph running optimally on a Windows 10 system (x86).

Many thanks for any help.

Hello @Hendrik,
It looks like you’re using cloud serverless?
Not 2.x? Im surprised you were able to write annotated csv at all through the UI. That seems like a bug.
I think you can actually only write line protocol through the influxdb UI in cloud. Annotated CSV is a Flux related format that exists in 2.x.

I’d try writing this data instead for example:

Hello,
thank you for your answer. I log in into https://cloud2.influxdata.com/signup, so I guess it is 2.0. I’m seemingly allowed to upload csv (your bitcoin historical data.csv). After all, it shows that the upload was successful. But I still don’t see the data from the csv in the bucket. This seems to be a bug, I would have liked to see an error message:

When I use LineProtocol with your example data it works, at least I can now see measurements. But now I’ am unable to see any data with the data explorer. Please see attached Screenshot: I’m trying to get the temperature data from Sensor TLM0100 but it is showing “No Results”.

I’m not allowed to upload another screenshot. Here is the sql command for the data I want to see:

SELECT *
FROM “airSensors”
WHERE
time >= now() - interval ‘5 minutes’
AND
(“temperature” IS NOT NULL)
AND
“sensor_id” IN (‘TLM0100’)

No Result. :frowning:

1 Like

Hello @Hendrik,
Yes I’m afraid that that upload success is a bug.
You’re using 3.x or serverless sorry that url is confusing.

Can you share a URL to that csv? You can only write line protocol to influxDB severless or 3.x. Annotated CSV is a InfluxDB 2.x feature.

Dear @Anaisdg,
To my amazement it works now, at least I can read in the sample data you provided via Line Protocol and actually read it out via the Data Explorer now. No idea what is different now that it works.

But upload via CSV still does not work.

Can you share a URL to that csv?

The CSV I used comes from you, more precisely from your Git repository. Or did I misunderstand your question?

https://github.com/Anaisdg/influxdb2-sample-data/blob/master/bitcoin-price-data/bitcoin-historical-annotated.csv

I just tried it with this CSV as a test. Is the file OK?
I am usually pretty sure that I am using Influxdb 2, as I also log in there via the “Influx DB cloud 2” login from the Influxdb main page. However, I can’t see anywhere in the UI which version it is. Is it possible to find out in the UI?

1 Like

@Hendrik,
yes you understood correctly I couldn’t remember where that repo was. It was a very old example.
If you click on the Cuboctahedron on the top left nave by “InfluxData” and then scroll all the way down. You can see at the bottom left under the blogs the version.