MQTT data not appearing in Explorer

Good evening

I am completely new to Influxdb and am trying to send a mqtt string in json format from a raspberry pi to influxdb cloud. Telegraf connects to the database without errors, but no data appears in explorer.
Herewith my config:

# Configuration for telegraf agent
  ## Default data collection interval for all inputs
  interval = "2s"
  round_interval = true
  metric_batch_size = 1000
  metric_buffer_limit = 10000
  collection_jitter = "0s"
  flush_interval = "10s"
  flush_jitter = "0s"
  precision = ""

  hostname = "raspberrypi"
  omit_hostname = false

  urls = [""]
  token = "jsyaF3KIxs2Mk8qpD8VVhWqbbMKfEUbUPQryZLBkCxlH8ZP7LsvQx76utVV2-A0i3QBLpU1LyrNXc5UU_O7xIQ=="
  organization = "MyOrg"
  bucket = "MQTT_Rpi_Bucket"

  servers = ["tcp://"]
  topics = ["rpi/raspberrypi/#"]
  data_format = "json"

  ## Connection timeout for initial connection in seconds
  connection_timeout = "30s"

  ## Username and password to connect MQTT server.
  username = "user"
  password = "password"

Herewith the startup response from telegraf:

pi@raspberrypi:~ $ telegraf --config
2023-06-26T22:07:24Z I! Loading config:
2023-06-26T22:07:24Z I! Starting Telegraf 1.27.1
2023-06-26T22:07:24Z I! Available plugins: 237 inputs, 9 aggregators, 28 processors, 23 parsers, 59 outputs, 4 secret-stores
2023-06-26T22:07:24Z I! Loaded inputs: mqtt_consumer
2023-06-26T22:07:24Z I! Loaded aggregators:
2023-06-26T22:07:24Z I! Loaded processors:
2023-06-26T22:07:24Z I! Loaded secretstores:
2023-06-26T22:07:24Z I! Loaded outputs: influxdb_v2
2023-06-26T22:07:24Z I! Tags enabled: host=raspberrypi
2023-06-26T22:07:24Z I! [agent] Config: Interval:2s, Quiet:false, Hostname:"raspberrypi", Flush Interval:10s
2023-06-26T22:07:24Z I! [inputs.mqtt_consumer] Connected [tcp://]

This is an example of the json string I am sending:

{"state_topic": "rpi/raspberrypi/cpuload", "name": "raspberrypi CPU Usage", "unit_of_measurement": "%", "value": 5.8, "unique_id": "raspberrypi_cpuload"}

Any help would be greatly appreciated.

As an update. The issue was solved by creating a new bucket with the name “rpimqtt” which does not contain any underscores. Now it works perfectly.
My configuration remained exactly the same, so other than the naming convention of the bucket I don’t know what else could have been the problem.

I read the thread below where the same problem was experienced, and sure enough it worked.