Lost tag keys / values post upgrade to 1.4.2


I upgraded Influxdb from 1.3.6 to 1.4.2 and it seems to work fine for all databases except for one, where after the upgrade show tag keys does not return any values. I run all dbs with tsi1 index and I did the conversation as mentioned in the changelog.
There is no error in the logs, all tsm files are healthy and the system performs well.
I am a bit puzzled and not quite sure what to do as for this particular db, non of the measurements gets new tags, but data is written to it and new series are created, just no tags.

Is there a way to reload tags?

Thanks, Flavio

It seems that there are more instances of this problem. In fact it seems to be a systematic issue as this is happening on a HA setup and both dbs are equally affected.
Does anyone else experience the same?
Shall I open an issue?

Yes we have, just a single setup on a CentOS7 host with influxdb-1.4.2-1.x86_64

returns nothing

There are a few things to try here.

  1. Try it on 1.5.0 (releasing today, 3/6/18)
  2. Rebuild the TSI index again and see if it reproduces the defect
  3. If possible, share the broken tsi and/or tsm data so we can try to reproduce the defect
1 Like

How do you rebuild tsi index?

Fixed with your update influxdb-1.5.1-1.x86_64
(maybe because the update generated these indexes?)

No was to early, some have been fixed, but some are still not available. So please advise on how to rebuild.

Try using the buildtsi command here.