Line protocol write problem

Hi. I have a problem with the Influxdb 2.0 line protocol. I tried writing approximately 9000 points each with 16s interval. But when it passed and the influxdb logo was green I’ve checked the bucket, and points were written selectively, by approximately 5 minutes instead of 16s. It looks like line protocol was losing/avoiding most of the points during writes. The second thing I’ve noticed is that, when I earlier used the line protocol, some time must have passed before the influxdb logo indicated green, now it was like instant. I’ve done the upgrade to the latest version 2.0.7-1, but it didn’t help either.

Now I’ve written above 200k points (also with manual line protocol) and it worked perfectly, but the case of those 9k points didn’t changed.


Are all the line protocol records valid? What batch size are you using? What client are you using? What do the influxdb2 logs say during the period where your writing?

Hi. Yes, all records are valid because as I’ve said, the strange part is in the case of writing 200k points it works perfectly, but in the case of 9k there are problems occurred, and all records are always generated by the same script. I don’t know what you mean by the batch size so below I present the example line protocol: readings,met_id=123456 m1=3.6,t2=73.07,t3=47.0 1632614528.
I use the Influxdb 2.0 GUI Client. The logs don’t mention anything related to the line protocol when writing or after a short period of time.


Hm, can you share the script if it’s not massive, please paste it inside a <> code block

By the script, do you mean the write points? If so I attach the .txt file below because it’s 9k lines long.
I use the Influxdb 2 GUI Line Protocol writing, with manual entry and precision set to seconds.

line_protocol.txt (533.4 KB)

Thanks, but I was meaning the piece you’re using to actually write the data into influxdb. Guessing python. Or are you embedding these files in a wget/curl post request or something?