Line protocol is not working with InfluxDB 2.1.1

I am using InfluxDB 2.1.1 Server: 657e183 Frontend: cc65325 running on Ubuntu server 20.04.
I am trying to upload 58kB line protocol file:

Line protocol looks like this:

sensors,device_id=4,device_name=IFZRKO1,location=fuzerkomlos temperature=1.2,dew_point=1.0,humidity=99,wind_speed=0.0,wind_gust=0.0,pressure=1008.03,precip_rate=0.0,precip_accum=0.0 1671235440000000000
sensors,device_id=4,device_name=IFZRKO1,location=fuzerkomlos temperature=1.1,dew_point=0.9,humidity=99,wind_speed=0.0,wind_gust=0.0,pressure=1007.92,precip_rate=0.0,precip_accum=0.0 1671235740000000000
  1. Influx command directly on server (not working) :
    influx write --bucket test --file ifzrko1.txt
    output of this command is:
    ': bad timestamp write data: 400 Bad Request: unable to parse 'sensors,device_id=4,device_name=IFZRKO1,location=fuzerkomlos temperature=1.2,dew_point=1.0,humidity=99,wind_speed=0.0,wind_gust=0.0,pressure=1008.03,precip_rate=0.0,precip_accum=0.0 1671235440000000000

  2. When I tried to upload file using UI (not working) I get : Failed to write data - invalid line protocol submitted.

  3. When I tried to upload file copy and paste content of file manually using UI - It results in success.

  4. Also I tried to upload file to Cloud AWS influxDB - It results in success.

It is always same line protocol but it is resulting in error in InfluxDB 2.1.1 why?

@D_B I’m guessing it has something to do with the newline character used in your line protocol. The UI form field is likely removing unsupported whitespace characters where the uploader and the CLI are not. This is just a guess though.