Kapacitor 1.3.x not enabling alerts


#1

Hi.
Since Kapacitor 1.3.x … when adding a new Database to a task…it wont fetch points from it…even if it should alert.

Kapacitor Logs neither show real info regarding kapacitor behavior

I am ready to send to anyone any data just to get some help

Thanks


#2

Can you share the define command you ran and the output of kapacitor show for your task?


#3

Hi nethaniel…
I check all kapacitor system…after the upgrade…Kapacitor sets influxdb as false…and it keeps getting the old databases points…but new ones no cause the influxdb integration is set to false…

I changed it to true and the issue was solved…

for the future updates…the package shouldnt change the kapacitor.conf file… but thank you anyway


#4

What configuration value was changed? What do you mean by?


#5

[[influxdb]]

Connect to an InfluxDB cluster

Kapacitor can subscribe, query and write to this cluster.

Using InfluxDB is not required and can be disabled.

enabled = true <------ THIS WAS SET TO FALSE AFTER UPGRADE
default = true
name = "localhost"
urls = [“http://localhost:8086”]


#6

@gmajlis Hmm, I am not sure how that happened. The default configuration is still set to true. What platform are you using and how did you perform the upgrade? I’d like to figure out how this happened as I agree with you that is not correct for an upgrade to change the config.


#7

Hey Nathaniel

I have 2 different servers…One CentOs 6 and the Other ubuntu 14.04
with apt-get and yum I made the package upgrade…never had those kind of issues…
Still didn’t upgrade our production stack…but on both of those servers I had the same problem

I’ve been using TIK (without chronograf :smile: ) for a long time and this is the first time I got this issue.
Thank you anyway for your support :smiley:


#8

Hi Nethanel
long time…again kapacitor is making the same trouble… out of the blue…I cannot redefine the alerts to use other DBs on influx…what is wierd right now is that non influx config has been changed…