There was a problem creating 'Alert rule': failed to get InfluxDB client: no such InfluxDB config

Hi,

Im trying to create an Alert rule using latest Chronograf but whenever I tried, I get this message
“There was a problem creating ‘Alert rule’: failed to get InfluxDB client: no such InfluxDB config”

Nothing seems to work on any metrics. Threshold, Deadmon, Relative, all have the some issue. Doesnt matter also if I selected host or not with cpu, mem, etc.

Any help will be highly appreciated.

Hi,

Are you talking about InfluxDB 2 or InfluxDB 1? I’m slightly confused by the Chronograf and Kapacitor tags, but it sounds like you’re talking about InfluxDB 2.

Let me know and I’ll do my best to get you help :+1:

Hi,

Im talking about InfluxDB 1. The above configuration is for Kapacitor when creating alerts. I cant seem to create any Alert when going to Chronograf>Alert History>Create Alert.

Thanks!

Sorry, I don’t see an “above configuration”.

Can you screenshot the “Connections” from your configuration page, please?

Here

Thanks again!

Im also referring to this configuration in Chronograf:

Then when I tried to create an alert rule, I cannot save as it gives me the error:

Sorry for multiple post cause it says cant post more than 1 image for new users :slight_smile:

Thanks!
Frank

It looks like you’ve not added a Kapacitor connection on the connections page.

Do you have Kapacitor running somewhere?

I have added Kapacitor. It says Connected (in Green) from the first image

I also updated connection and save till finish from the above image and says Successfully connected

Sorry, but that’s your InfluxDB connection - not your Kapacitor connection.

If you see your first sceenshot, there’s a button for a new Kapacitor connection.

I have updated the connection and named it as Default. Updated settings and some alert settings. After Update, it says Kapacitor connected successfully

Creating alert, still has the same issue though

OK. I think, if you’re willing, the best way to solve this is via a video call with screenshare?

Before that though, can you confirm you have Kapacitor running somewhere? You have Kapacitor running on port 9092 on a machine?

Yes, Kapacitor is running on localhost at port 9092.

Are you on our Slack channel? Can you DM me, please? Thanks

http://influxdata.com/slack