Installing, error: The repository 'https://repos.influxdata.com/raspbian bullseye Release' does not have a Release file

Dears
I am on Raspbian 11.
I try to install telegraf following docs.influxdata.com/telegraf/v1.20/introduction/installation/
.
I am getting the error:
sudo apt-get update && sudo apt-get install telegraf
Hit:1 …archive.raspberrypi.org/debian bullseye InRelease
Hit:2 …raspbian.raspberrypi.org/raspbian bullseye InRelease
Hit:3 …packages.grafana.com/oss/deb stable InRelease
Ign:4 …repos.influxdata.com/raspbian bullseye InRelease
Err:5 …repos.influxdata.com/raspbian bullseye Release
404 Not Found [IP: 13.32.12.60 443]
Reading package lists… Done
E: The repository ‘…repos.influxdata.com/raspbian bullseye Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by
.
If i try to add:
wget -qO- https://repos.influxdata.com/influxdb.key | sudo apt-key add -
I get an error as well:
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).

So I am stuck:)

Any advice appreciated

Hi!

Hi,

Please use debian instead of raspbian. We do not keep up with all the various distros and all their releases in our repo, since Raspbian is essentially Debian you can safely swap between those two for our repo.

The readme shows how to use something other than apt-key:

wget -qO- https://repos.influxdata.com/influxdb.key | sudo tee /etc/apt/trusted.gpg.d/influxdb.asc >/dev/null

Thanks!

Hi @jpowers,

thank you for your first response. I tried your snipped and the complete snipped in the readme you linked but the result stays the same.

Ign:4 https://repos.influxdata.com/raspbian bullseye InRelease
Fehl:5 https://repos.influxdata.com/raspbian bullseye Release
  404  Not Found [IP: 2600:9000:224a:7e00:7:7790:e740:93a1 443]

I tried to install influxdb2 and telegraf - both without success and same error (I know it’s the same repository).
Seems like there is something missing in the repository?
I’m just a rookie in the linux world so any friendly help and hint is appreciated.

Hi @wbuh2018,

Try the following:

echo "deb https://repos.influxdata.com/debian bullseye stable" | sudo tee /etc/apt/sources.list.d/influxdb.list
sudo apt update
sudo apt install telegraf
1 Like

Dear @jpowers,
perfect! Worked like a charm.
Spent two hours with trial and error before.
Thank you very much!

1 Like