[inputs.ping] Error in plugin: , exit status 3221225794: X.X.X.X

Hi All,

im having this issue with using input ping on windows, using latest build of telegraf, and any version prior.

We are pinging 201 ip’s at an interval of 60 seconds,
And don’t have anything special in the config.


List of urls to ping

urls = [
“X.X.X.X” (we have 201 ip’s in this list)
] # required
count = 3
timeout = 2.0

We are running telegraf on an Windows 2016 server, AV disabled, DEP Disabled, FW Disabled, just updated to latest telegraf,

we just released Telegraf 1.17.3, so be sure to test that out, but also try method = "native" to see if you get better results from that.

still not working, same issue

native works, but have another issue open on git regarding that.

we released an update to ping since this post. Please upgrade to the latest Telegraf and try it out. if you’re still having problems, I’d encourage you to open a new issue detailing the problem.

I have tried it with all the builds, which came out since i found the issue. Still not working :frowning:
Even the latest.