Influxdb: Out of memory /var/log/messages


I have problems with /var/log/messages,each 2 days, i find my machine with out of memory because Influx is writing logs also in /var/log/messages.

How i can fix this? Can I have any solution about it?

It Is frustrating to have this machine in that way.

Are you running out of memory or disk space?

100% in /var, surfing… i can see /var/log/messages writing everything about influx logs, but i had this messages too:


So , I dont know exactly.

You could turn off http request logging in /etc/influxdb/influxdb.conf and reload InfluxDB:

  log-enabled = false

You could also look into changing your log rotation settings, this is system dependent but on debian you may just need to modify /etc/logrotate.d and check man logrotate.

I included in logrotate it’s better but I have to try changing config too. I will tell you if it works. Thanks!

I checked my influxdb.conf and I already had this parameter in false.

It’s better with rotatelog but /var is full again.

So, I dont know if i have any option more to fix it.

Is it still the logs taking all the space, remember the database also uses /var so at some point I think you will just need more space.

I know you could completely disable logging, at least when using sysvinit, by setting STDERR=/dev/null, here are the logging docs. Of course this will make it very hard to debug what is going on so I don’t really recommend it.

I found the solution, it was so simple, in influxdb.conf, it is necessary to change, because I had that in true:

write-tracing = false

I missed to check before!

Thanks for all!