InfluxDB not sending subscriptions to Kapacitor

Hi all,

I am running an installation of InfluxDB, Kapacitor and Chronograf on Kubernetes. I installed the 3 products using the official Helm charts from the stable repository. All deployments are up-to-date.

I enabled authentication on influxdb, which meant I had to manually edit the Kapacitor config file in the configmap, as there is no way to configure authentication on the helm chart - but that is another story.

Kapacitor works when running in batch mode, but it does not receive any points when running in stream mode. When I run “kapacitor stats ingress” the list is empty - not a single entry.

I think the problem lies with influxdb somehow. When I run “SHOW SUBSCRIPTIONS” it shows all the subscriptions. The endpoint is correct. I used curl from the influxdb pod to see if I could reach the endpoint and I can (it results in a 404 not found JSON message, but it responds).

I even ran tcpdump on both the kapacitor and the influxdb side and it seems no data is actually being sent from influx to capacitor, despite the subscriptions existing and the endpoint being correct.

I even tried in UDP mode by editing the configmap again and cycling the pod - the subscription endpoints changed to http to udp, but still no data.

What am I missing here? Why is influxdb not sending data to its subscriptions?