Influx not connected / connection refused

I have problems with grafana/influx.
Influx is installed on a RaspberryPi4 with 4GB RAM in an ioBroker environment. After working flawlessly for some months recently it stopped working.
ioBroker log indicates error:
Error: connect ECONNREFUSED
After a new install of influx and a restore of the database it worked again for some days but stopped now.
When calling “Influx” in monitor I get this response:

pi@raspberrypi:~ $ influx
Failed to connect to http://localhost:8086: Get http://localhost:8086/ping: dial tcp [::1]:8086: connect: connection refused
Please check your connection settings and ensure 'influxd' is running.
pi@raspberrypi:~ $

Influxd is running and listening

pi@raspberrypi:~ $ sudo netstat -tulpn | grep LISTEN |grep influx
tcp        0      0*               LISTEN      13217/influxd
pi@raspberrypi:~ $

indeed it seems to listen on 8088.

as you can see in the influxdb.conf the Port 8088 is not selected

# The values in this file override the default values used by the system if
# a config option is not specified. The commented out lines are the configurati>
# field and the default value used. Uncommenting a line and changing the value
# will change the value used at runtime when the process is restarted.

# Once every 24 hours InfluxDB will report usage data to
# The data includes a random ID, os, arch, version, the number of series and ot>
# usage data. No data from user databases is ever transmitted.
# Change this option to true to disable reporting.
# reporting-disabled = false

# Bind address to use for the RPC service for backup and restore.
# bind-address = ""

wheras in http section the correct Port 8086 is configured.

  # Determines whether HTTP endpoint is enabled.
enabled = true

  # Determines whether the Flux query endpoint is enabled.
  # flux-enabled = false

  # Determines whether the Flux query logging is enabled.
  # flux-log-enabled = false

  # The bind address used by the HTTP service.
bind-address = ":8086"

I check the installation

pi@raspberrypi:~ $ sudo apt update

Get:1 bullseye InRelease [23.7 kB]

Get:2 bullseye InRelease [15.0 kB]

Hit:3 stable InRelease

Hit:4 bullseye InRelease

Hit:5 bullseye InRelease

Get:6 bullseye/main armhf Packages [13.2 MB]

Get:7 bullseye/main armhf Packages [297 kB]

Fetched 13.6 MB in 9s (1,503 kB/s)

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

All packages are up to date.
pi@raspberrypi:~ $ apt policy influxdb*


  Installed: (none)

  Candidate: 1.6.7~rc0-1

  Version table:

     1.6.7~rc0-1 500

        500 bullseye/main armhf Packages


  Installed: (none)

  Candidate: (none)

  Version table:


  Installed: 1.8.10-1

  Candidate: 1.8.10-1

  Version table:

 *** 1.8.10-1 500

        500 bullseye/stable armhf Packages

        100 /var/lib/dpkg/status

     1.6.7~rc0-1 500

        500 bullseye/main armhf Packages

pi@raspberrypi:~ $

Finally I tried again to call influx again and got this response:

pi@raspberrypi:/etc/influxdb $ influx
Connected to http://localhost:8086 version 1.8.10
InfluxDB shell version: 1.8.10
> show databases
ERR: Post http://localhost:8086/query?chunked=true&db=&epoch=ns&q=show+databases: dial tcp [::1]:8086: connect: connection refused

Suddenly it seems able to connect but cannot find any databases but still waiting for some input.

Has anybody an idea what I got wrong with this installation and how I can repair that?

Regards Gerhard