Inexplicable non-working CLI - "TLS handshake timeout"

Hi,

I have been struggling to get the Influx CLI to function on one of my systems (windows server). I’ve set up Influx such that it uses TLS certificates from our certificate authority. All that seems to work fine for accessing the GUI and for writing data to influx from other applications, however the CLI is struggling.

The weird part is, the CLI is working fine on one system but not on the other, even though they are essentially identical. I’ve already tried rebooting the server. Both use v2.7.5. I’m running the CLI’s from the same VM that runs the InfluxDB instance I’m trying to connect, so it cannot be network related.

I’m open to suggestions.

Please and thanks :slight_smile:

Hi bhuijlgredainku,
Honestly, it seems you have a connectivity issues - something between the CLI and the server.
Can I assume you have checked all the obvious possible impediments, ports, firewalls, router/NAT/redirection, etc?
Dave

I have even shut off the local firewalls completely. However, both the CLI and influxdb are running on the same system so I don’t think it even touches the firewalls at all.

tnc seems to agree with that as well.
Screenshot 2024-05-15 104109

I don’t know what else there could be at this point.

OK, so I think the next step is to see whether the server will answer. One of my collogues has offered the following test which you might try: curl -v https://influxdb:8086/ping

Hang in there, we’ll figure it out!

Hi,

Thank for the help.
I have in the mean time gotten desperate enough to re-install influx completely. Now I’m on version 2.7.6, but it did not help.

Here’s the result, I don’t know what to make of that. I have ran this test on the working system too and it gave the same result there.

Screenshot 2024-05-16 084030

I’m asking for help - stay tuned.

I have tried something else. I took the TLS certificate off and reverted back to using http. The CLI does work under http. So I would suspect it is something to do with how influx (or rather influx_cli, because other applications have no problem connecting to it over https) is handling the TLS handshake.

Hi,

I took the TLS certificate off and reverted back to using http. The CLI does work under http.

Awesome, so connectivity can work between the two.

To ensure I understand your setup, it sounds like you have a locally running InfluxDB with some custom certificates on Windows?

Are those custom certificates installed on the client’s System Root Certificate store as well? The client will need access to them to validate the server’s certs.

1 Like