I can't install my SSL certificate

Hi, I’m tying to install my SSL certificate in my influxb v2.7.5 but I can’t, if i follow the official guide I do the command:

influxd \
--tls-cert="/etc/certificati/completo.crt" \

and after it works but if i go to https://localhost:8086/ it’s like I have to reconfigure my instance with new tokens and buckets, and when i exit to the CLI influxdb get restart in HTTP (and my buckets/token return).

how can i improve my SSL certificate in my config.toml? I have tried many times to install it without success, my config only has these two lines:

bolt-path = “/var/lib/influxdb/influxd.bolt”
engine-path = “/var/lib/influxdb/engine”

I also tried to put [http] but the service doesn’t start while if I put [https] it starts but:
1- I access in HTTP and in HTTPS it gives me this error: “ERR_SSL_PROTOCOL_ERROR”
2- from the influx logs I can see that it requires a token(?): “influxd-systemd-start.sh[9460]: ts=2024-04-18T08:16:40.077928Z lvl=info msg=Listening log_id=0od4JKmW000 service=tcp-listener transport=http addr=:8086 port=8086”

like this:

enabled = true
auth-enabled = false
bind-address = “:8086”
cert = “/etc/influxdb/certificati/completo.crt”
key = “/etc/influxdb/certificati/chiave.key”

Is it possible you have more than one influxd.bolt–you installed separately by accident? What paths are output when you start influxd with vs without https enabled? For example:

influxd --tls-cert="/etc/ssl/influxdb-selfsigned.crt" --tls-key="/etc/ssl/
2024-04-18T13:42:38.872131Z     info    Welcome to InfluxDB     {"log_id": "0odMyG5W000", "version": "2.7.5", "commit": "09a9607fd9", "build_date": "2024-01-05T16:21:16Z", "log_level": "info"}
2024-04-18T13:42:38.879258Z     info    Resources opened        {"log_id": "0odMyG5W000", "service": "bolt", "path": "/Users/ja/.influxdbv2/influxd.bolt"}
2024-04-18T13:42:38.879760Z     info    Resources opened        {"log_id": "0odMyG5W000", "service": "sqlite", "path": "/Users/ja/.influxdbv2/influxd.sqlite"}
2024-04-18T13:42:38.896750Z     info    Checking InfluxDB metadata for prior version.   {"log_id": "0odMyG5W000", "bolt_path": "/Users/ja/.influxdbv2/influxd.bolt"}
2024-04-18T13:42:38.896933Z     info    Using data dir  {"log_id": "0odMyG5W000", "service": "storage-engine", "service": "store", "path": "/Users/ja/.influxdbv2/engine/data"}