How to configure collectd for influxdb 1.8


I’ve problems to with the collectd plugin of influxdb, running on Fedora Server 33.

After long tests I had a working configuration for version 1.8.3 (influxdb-1.8.4_linux_armhf.tar.gz) but I lost this configuration during updating to v1.8.4 (influxdb-1.8.4_linux_armhf.tar.gz). With the lost configuration collectd on OpenWrt was able to write data to InfluxDB, but now the data will not written to database, even with firewalld disabled. OpenWrt send data to the IPv4 address (verified with tcpdump).

Following configuration is defined for collectd plugin (reported by influxd config):
enabled = true
bind-address = “:25826”
database = “collectd”
retention-policy = “”
batch-size = 5000
batch-pending = 10
batch-timeout = “10s”
read-buffer = 0
typesdb = “/usr/share/collectd”
security-level = “none”
auth-file = “/etc/collectd/auth_file”
parse-multivalue-plugin = “split”

InfluxDB is only listening to UDPv6:
netstat -tulpen | grep influxd
tcp 0 0* LISTEN 986 39190 828/influxd
tcp6 0 0 :::8086 :::* LISTEN 986 37840 828/influxd
udp6 0 0 :::25826 :::* 986 37841 828/influxd
I forced IPv4 only in systemd unit or used fixed IPv4 address, the new OpenWrt data is not written to database.

What is necessary to make InfluxDB listen on UDPv4 and UDPv6? How to debug why data is not written to database?

Thanks in advance!