Grafana - InfluxDB Error: undefined


Trying to configure grafana to use InfluxDBv2.
When connecting I see this:

I have done the following:

  • Confirmed InfluxDB is listening on 8086 on localhost
  • tested telnet access to Influx 8086 to see the tcp port is open.
  • Performed a “influx query” with my token, this worked.
  • Tried “Basic Auth” with the same login creds for InfluxDB
  • tried a bad username I know does not exist - same error
  • tried a bad ip / port I know is not listening on the host - same error.

What is strange to me is grafana uses the word “Database”, however I see no where in InfluxDB where there are databases. Is a bucket a database? What would be causing this problem?

Why am I getting this error?

One more note. Grafana is running as a docker container, InfluxDBv2 is running as a systemd service on the host. Is this a network issue? I tried doing a docker exec into grafana but there are no tools for me to test (telnet, nc) to see if it can connect to localhost:8086, any recommendations?

It looks like an InfluxDBv1 connection to me.
Which Grafana version do you use?
What can you select under Type property?


Dropping down type only shows InfluxDB, Elasticsearch, Graphite, InfluxDB, OpenTSDB, and Prometheus.
The docker container shows “grafana:4.2.0”, which appears to be ancient.
I have another grafana running version 7.3.7 used for a different service on a different host. When adding the “InfluxDB” data source there I have access to different query languages such as InfluxQL and Flux. Be aware this Grafana cannot be used as it is on a different VPN.
I assume that is the problem?
If I wanted downgrade influxDB instead of upgrade Grafana, where can I get access to 1.x .deb files? The InfluxDB site does not seem to share these anymore. I tried compiling from source that that became a mess quickly. Rather just get the .deb file for older version, to test on this version of Grafana.

Yes, your grafana version seems to be way too old to support InfluxDBv2 data source.

Go down to 1.x on the download page:

However, i would opt for upgrading grafana instead of downgrading influxdb.

There is no 1.x listed, see image below. Any other place I can try?

But of course, go further down the page and unfold:

Are you interested in InfluxDB 1.x Open Source?

Right, that only gives me the source code, whereby I need to compile from source, which I ran into brick walls doing so. Also these are the same files you can get from the github page.

I am looking for 1.X .deb files. The package of precompiled installable files. Where can I find that?

Select Ubuntu & Debian

@Franky1, Ah your right, the tar.gz is actually the binaries compiled, just need to place them and the systemd unit where I want. Nice.
However I ended up just using an older docker container for testing. This fixed my problem, and is cleaner since Grafana is running as a container as well. At some point, will plan to upgrade everything to the latest. However I am currently anchored in to these older versions based on a older solution I am using for telemetry data. Once I get this solution working, I will work to adjust source and upgrade.
Thank you for your help!