Different behaviour between influx2.0 beta and 2.0 [backup / restore / OSS]

I have some problems switching from beta to production release of influxdb and I can’t manage to figure our the solution or any reason why it might not work. Everything works flawlessly until I try to make a backup and then restore it.

In 2.0 beta (16 I think) it worked that way:
influx backup --token $influx_token ./backup
and then:
influxd restore --backup-path ./backup
It used to recover whole DB including users, tokens and obviously the data.

Starting from rc version influxd restore was moved (or replaced I don’t know the details) to influx restore and now I am not able to restore any backup. And I mean backups already created by the new version of influx backup. Usually there is some Internal Error without any description. Besides documentation confuses new influxd restore with influx restore, mentions to stop influxd server (but with stopped server influx restore can’t find api on http://localhost:8086) and it’s not very consistent.

Anyway I am puzzled by those changes, simple backups (without data) are working but I fail to observe any consistent behaviour. I also failed to find any guide / docs / tutorial that might help me out that’s why I am writing here. Plus there started to throw ulimit errors which were absent on beta16 no matter how much data I tried to dump. I tried to make everything work inside AWS on Amazon Linux 2 machines with AMI: "ami-09b89ad3c5769cca2".

For now I am going to stick to the beta16 version for some more time, but would love to switch to production one. Thanks :slight_smile: