Configuration specified the fields ["vcenters" "username" "password" "vm_metric_include"], but they weren't used

Just created a fresh install with docker containers for influxdb, telegraf and grafana. Telegraf is working and in grafana I can see the metrics.

Now I would like to collect data from my vCenter 7.0 environment. When changing the telegraf.conf and reloading the telegraf container, I get the following error and I have no clue on what the error is telling me:

[telegraf] Error running agent: Error loading config file /etc/telegraf/telegraf.conf: plugin inputs.system: line 2331: configuration specified the fields ["vcenters" "username" "password" "vm_metric_include"], but they weren't used

I have made the following change to my already working telegraf config:
vcenters = [ “https://fqdn-to-my-vcenterserver/sdk” ]
username = “administrator@vsphere.local”
password = “password”

Mind you, the database currently only has the default measurements when I run “show measurements;” and according to the guide (Guide) I’m following it should also show some vsphere_ measurements, but I guessed these get created when the connection is working???

Any help on what “but they weren’t used” is telling me would be great.

Solved it.
I had forgotten to uncomment the inputs line:

# Read metrics from VMware vCenter


Leaving this here for others that might run into this.