Chronograf is not reachable via browser

I run Chronograf in Docker container:

docker run -d --name chronograf --link influxdb:influxdb -p 8888:8888 chronograf

Logs say "Serving chronograf at http://[::]:8888" But I am not able to reach Chronograf at server_name:8888 in browser

curl server_name:8888 shows:

<!DOCTYPE html>
    <meta http-equiv="Content-type" content="text/html; charset=utf-8"/>
  <link rel="shortcut icon" href="/favicon.ico"><link href="/chronograf.css" rel="stylesheet"></head>
    <div id='react-root' data-basepath=""></div>
  <script type="text/javascript" src="/manifest.32071f6a3b322afbc407.js"></script><script type="text/javascript" src="/vendor.eca9139b10755c39e440.js"></script><script type="text/javascript" src="/app.fd800f0cb655596f5086.js"></script></body>

Did I miss any settings?

If you want to run the whole stack in docker I would advise checking out our sandbox. Its got a docker compose file in there with all the proper settings.

If you are running like you describe above there a number of ways that could be going wrong. Have you tried to reach chronograf at localhost:8888?

I tried curl localhost:8888 but I am not able to reach it from browser on different machine

@Steven_1 Have you checked firewalls?

I have. I am able to reach InfluxDB UI but not Chronograf.

@Steven_1 Its pretty hard for me to help you debug this problem if I don’t know anything about where your instance is running and the networking around it. Could you give me some more information about that? Also the output of docker network ls might help.

That is kind of strange.
My version of Docker doesn’t support “network”, I am using “link”. But that shouldn’t be an issue, moreover I am getting correct response curl server_name:8888.

This is Chronograf log and I think it looks good:

time="2017-05-31T19:05:57Z" level=info msg="Serving chronograf at http://[::]:8888" component=server
time="2017-05-31T19:05:57Z" level=info msg="Reporting usage stats" component=usage freq=24h reporting_addr="" stats="os,arch,version,cluster_id,uptime"
time="2017-05-31T19:27:55Z" level=info msg=Request component=server method=GET remote_addr="xxx.xx.xx.x:43370" url=/
time="2017-05-31T19:27:55Z" level=info msg="Expected http.ResponseWriter to be an http.Flusher, but wasn't"
time="2017-05-31T19:27:55Z" level=info msg="Serving assets" component=server method=GET remote_addr="xxx.xx.xx.x:43370" url=/
time="2017-05-31T19:27:55Z" level=info msg="Response: OK" code=200 component=server remote_addr="xxx.xx.xx.x:43370" response_time=3.103492ms