Chronograf Dashboard Giving No Results

Hello,

First time posting and relatively new to the influxdata applications. First off great set these guys have produced, absolutely loving the ease so far of getting what I need out of them.

I have got some data going into influxdb via the mqtt plugin of telegraf. No issues with any of that. The payload of my mqtt topic is formatted in influx line protocol and has the timestamp on the end in unix down to the ns. The timestamp of the event is quite crucial for my application so this is why the timestamp is in there, I do not want the data in influxdb to be timestamped with the time it is written into the database.

The issue I am experiencing is within chronograf. If I have a query using “WHERE time > :dashboardTime:” it will always return no results. If I then stop sending messages containing a timestamp I can get the dashboards in chronograf to work as desired. Put the timestamp back in and it all falls apart.

I do not want to hardcode a time > now() - 1 day into the query as I want the user to be able to do this via the relative time picker at the top of the graphs.

Has anybody experienced this issue or know how to get around it?

@Storm_Trooper If I had to guess, this sounds like the precision of your timestamps doesn’t match what InfluxDB is expecting. By default, InfluxDB assumes timestamps are in nanoseconds. If the timestamps you’re providing aren’t nanosecond timestamps, then they are likely falling outside of your query time range.

1574208000000000000  -->  2019-11-20T00:00:00Z
1574208000000        -->  1970-01-01T00:26:14Z

Just be sure that you’re actually sending ns timestamps.

@scott See below some example messages that are being sent.

TestEvents,Equip=T09-238 GlobalID=50957761,Tag=0014822292 1564640520887000000
TestEvents,Equip=T09-238 GlobalID=50957762,Tag=0014730789 1564640530592000000
TestEvents,Equip=T09-238 GlobalID=50957763,Tag=0014821289 1564640534947000000
TestEvents,Equip=T09-238 GlobalID=50957764,Tag=0014822196 1564640542697000000
TestEvents,Equip=T09-238 GlobalID=50957765,Tag=0014822197 1564640548852000000
TestEvents,Equip=T09-238 GlobalID=50957766,Tag=0014822291 1564640555092000000
TestEvents,Equip=T09-238 GlobalID=50957767,Tag=0014771419 1564640560407000000
TestEvents,Equip=T09-238 GlobalID=50957768,Tag=0014753145 1564640566912000000
TestEvents,Equip=T09-238 GlobalID=50957769,Tag=0014822233 1564640579747000000
TestEvents,Equip=T09-238 GlobalID=50957770,Tag=0014807891 1564641847012000000
TestEvents,Equip=T09-238 GlobalID=50957771,Tag=0014721469 1564641850102000000
TestEvents,Equip=T09-238 GlobalID=50957772,Tag=0014721470 1564641856767000000
TestEvents,Equip=T09-238 GlobalID=50957773,Tag=0014823386 1564641860117000000
TestEvents,Equip=T09-238 GlobalID=50957774,Tag=0014806176 1564641866282000000
TestEvents,Equip=T09-238 GlobalID=50957775,Tag=0014820933 1564641869902000000
TestEvents,Equip=T09-238 GlobalID=50957776,Tag=0014819934 1564641873607000000
TestEvents,Equip=T09-238 GlobalID=50957777,Tag=0014723448 1564641876887000000
TestEvents,Equip=T09-238 GlobalID=50957785,Tag=0000000000 1564641884637000000
TestEvents,Equip=T09-238 GlobalID=50957779,Tag=0014824761 1564641888422000000
TestEvents,Equip=T09-238 GlobalID=50957780,Tag=0014824204 1564641891683000000

@Storm_Trooper, looks like your timestamps are good. That sample dataset covers the following timerange:

1564640520887000000 --> 2019-08-01T06:22:00.887000000Z
...
1564641891683000000 -- >2019-08-01T06:44:51.683000000Z

Is the selected date/time range in your dashboard set to pull data from August of this year?

@Storm_Trooper,
What version of InfluxDB and Chronograf are you using?

@scott I have tried with the date picker to go back to the date from August and it does not work. I have also tried updating the timestamp so that the date falls within the last 24h relative date selection and it does not work. All I get is “Your query is syntactically correct but returned no results”

@Anaisdg InfluxDB is on version 1.7.9 and Chronograf is on version 1.7.14

@Storm_Trooper,
Can you please share two screen shots?

  1. of chronograf with the query with the absolute times that works
  2. of chronograf with the query with the dashboard times that doesn’t

Thank you,
Anais

@Anaisdg
Loaded the following 5 entries into InfluxDB:
TestEvents,Equip=T09-238 GlobalID=50957761,Tag=0014822292 1574310120887000000
TestEvents,Equip=T09-238 GlobalID=50957762,Tag=0014730789 1574306530592000000
TestEvents,Equip=T09-238 GlobalID=50957763,Tag=0014821289 1574302934947000000
TestEvents,Equip=T09-238 GlobalID=50957764,Tag=0014822196 1574299342697000000
TestEvents,Equip=T09-238 GlobalID=50957765,Tag=0014822197 1574295748852000000

And Murphy’s law now it is working from the relative selected on the dashboard.

1 Like

@Storm_Trooper,
Glad to hear it’s working again! Just make sure to take a screen shot if it’s not working again, and we’ll try to get to the bottom of it.