Can't get Flux working in windows installation

Hi There,

I’ve tried for a while now to get Flux working, followed all the config file instructions. but the flux option in chronograf remains disabled even with the latest versions released.

Any suggestions? Thanks in advance.

[http]
  # Determines whether HTTP endpoint is enabled.
  enabled = true

  # The bind address used by the HTTP service.
  bind-address = ":8086"

  # Determines whether HTTP authentication is enabled.
  auth-enabled = true #this is recommended but not required

[...]

You’ll need to add a flux-enabled option to the [http] section of the config, which the example you included doesn’t have:

[http]
  # Determines whether HTTP endpoint is enabled.
  enabled = true

  # The bind address used by the HTTP service.
  bind-address = ":8086"

  # Determines whether HTTP authentication is enabled.
  auth-enabled = true #this is recommended but not required

[...]

  # Determines whether Flux is enabled.
  flux-enabled = true

Thanks for the reply, unfortunately I pasted the wrong config and not the one from my VM where I was trying to get it working…mine looks like this, are there any other settings else where to look for?

[http]
  
  enabled = true  
  flux-enabled = true  
  bind-address = ":8086"  
  auth-enabled = true  
  realm = "InfluxDB"  
  log-enabled = true
  suppress-write-log = false

This looks correct.

Can you provide more information? You’re running in a Windows VM? What version of Windows? How did you install the software? How are you starting it? Where are your config files located and what are their contents?

You can use Markdown to format your response to make it easier to read.

I’ve tried it on a home pc running Server 2012 R2 and a fresh Server 2016 VM on Azure.

I just downloaded it and extracted each relevant product its own folder in c:\InfluxDb so C:\InfluxDb\influxdb-1.7.2_windows_amd64\ and C:\InfluxDb\kapacitor-1.5.2_windows_amd64 etc.
So the config files are in the same folders as the .exe files.

I run influxd.exe, chronograf.exe, kapacitord.exe

chronograf and grafana etc work fine, just the Flux option is greyed out in chronograf and says the current source does not support Flux.

I did the basic config of the files which are appear quite straight-forward. I’ve written c# applications that read/write just fine to InfluxDB but using the InfluxQL syntax over http.

Did you manage to get this working, I have the same issue?

1 Like

It’s a bit late to answer but if you would be in this situation ,
make sure that you have flux-enabled = true in the configuration file influxdb.conf and that the correct configuration file is used because
influxd can be started even if it doesn’t find the configuration file in the default locations.
In that case it will start with default parameters which is not what you expect …
An option would be to use influxd -config yourconfigfilehere