Cannot restore backup on new machine ("Error: no backup manifests found at..")

I have InfluxDB OSS v2.5 running fine for years on a Debian machine. I make backups 3x per day and they are all fine.

I recently built two new Ubuntu servers running 22.04 and installed InfluxDB OSS v2.7. I want to restore a backup from the v2.5 machine to the two v2.7 machines. On both servers, I carefully followed these instructions to ensure the admin token from the v2.5 machine was used in the setup of the v2.7 machines, and it worked fine, i.e.

influx setup --token My5uP3rSecR37t0keN

A few weeks ago, on the first v2.7 machine, I successfully restored the backup to the first new server using

influx restore /backups/2024-04-08-0800/  --full

Today, on the second v2.7 machine, I tried the same command as above, but got:

Error: no backup manifests found at "/backups/2024-04-08-0800/"

I looked into the contents of the 2024-04-08-0800 folder and can see a file 20240408T120001Z.manifest

I have searched for this error and cannot find much (maybe this unanswered post from ~3 years ago)

Please help, as this error message seems misleading and I have no reason to see why the backup should not work.

Answering my own question…

When I successfully did the restore on Machine #1, I restored the backup which was on a USB flash drive using:

./influx restore /media/USB/2024-04-08-0800/ --full

When I attempted the restore on Machine #2, I had copied the backup from the USB and placed it into Documents. So the error which I actually got (contrary to what I wrote above, which was simplified) was:

Error: no backup manifests found at "/Documents/2024-04-08-0800/"

On Machine #2, I moved the backup from Documents to the root directory and then used the command

influx restore 2024-04-08-0800/ --full

which worked successfully.

Hope this helps others down the road…

@grant1 thank you so much for sharing your solution with the community! I appreciate you!