Cannot enter a timestamp using Line Protocol on CloudDB

It seems I cannot enter my own timestamp when ingesting data using line protocol.
When I manually enter this line taken from InfluxDB help screen:

myMeasurement,tag1=value1,tag2=value2 fieldKey="fieldValue" 1556813561098000000

I get this error:


If I drop the timestamp it works:

myMeasurement,tag1=value1,tag2=value2 fieldKey="fieldValue" 

Any idea?

Hello @dinofm,
What version of influxdb are you using?
I tried writing your data to influxDB Cloud and it worked :slight_smile:

Dear Anais
I’m on Influx Db cloud as well:


Dear Anais, any update on this?

You don’t mention what time granularity you specified on the connection. It looks like you are using ns
There is a 4th (optional) parameter on the api client that is used to specify the granularity e.g ‘ns’ or ‘ms’ …
E.g. write_api.write(bucket=,record=,precision=‘ns’)

Daer Tom

I’m using the Interctive line protocol window on the GUI.
Let’s assume my Unix timestamp is 1656367200 (seconds since the origin of Unix time).
I add 9 zeros to convert to ns and enter the line protocol text:

This doesn’t work. If I use the original timestamp and set precision to seconds doesn’t work either:

My original example is taken from the Help text on the same page: it’s in ns. and matches the default ns precision

On my screen the top right has a selection window to set precision

Hi tom, yes my precision is set to nanoseconds as well and the Influx db timestamp is the Unix one times the number of ns in a second:

1656367200 * 1000000000

Stupid huh! My dropdown list ns - not NanoSeconds. Sorry I can’t help.