Always getting "mkdir /tmp/<123456789>: permission denied" on backup


i am trying to backup my influx data with influx backup --bucket <bucket> --token <token> /home/influxdb/<bucket>/ but i always get the error message Error: failed to backup metadata: failed to save local copy of SQL backup to "20221007T100456Z.sqlite": unexpected EOF.
In the logs i get the following message: ts=2022-10-07T10:04:56.541434Z lvl=warn msg="internal error not returned to client" log_id=0d0zf5mW000 handler=error_logger error="mkdir /tmp/263769048: permission denied".

For some reason it still creates two files (.bolt.gz and .sqlite.gz) but when i try to restore the data with those files it says Error: no backup manifests found at "/tmp/system/".

I have InfluxDB running as a Docker container with version 2.2.0.

Hello @Leon3011,
Can you execute other commands with the CLI?
What about influx bucket list?
It sounds like you need to provide a new token for either your CLI config or for the --token parameter.
I would try recreating a new all access token.

Hello @Anaisdg,
Thank you for your answer.
I tried influx bucket list -o abc -t xyz and i got a list with all the buckets, so that seems to work.
I tried to create a new all access token but i think only the first one is allowed to actually do a backup because with the new one i get 401 Unauthorized: read:authorizations is unauthorized. But if i try again the bucket list command with new token it work’s.

Do you have any other ideas :slight_smile:?

Helllo @Leon3011,
What version of InfluxDB are you using? I thought this was fixed but I could be wrong.
If that’s the case you might have to start up a new instance.

Hello @Anaisdg,
i was using 2.2.0.
I updated it to 2.5.0 and now it is working. Thank you for your help.

1 Like

@Leon3011 Yay! I’m happy that was an easy fix.