Upgrading Nightmare from 1.8 to 2.x

I’ve been using 1.8 for more than two years to log data from a PV generator, a wall box, and solar forecasts. As only 2.x offers cross-measurement queries I feel I should look into upgrading.

I spent a few hours on this but failed miserably. First I thought I could do a -portable backup of the 1.8 installation and somehow restore this portable backup in 2.x, but that didn’t work as the restore command in 2.x doesn’t seem to read the 1.8 backups.

Then I tried copying the /var/lib/influxdb folder from my 1.8 to my 2.7 installation, added the “upgrade” parameter to /etc/default/influxdb2 file and launched.

This did something (?) but I was unable to move on; I was unable to authenticate to the new 2.x installation. I tried generating a token but failed for 401 messages.

influx auth create --org My --all-access

Error: failed to lookup org with name “My”: 401 Unauthorized: unauthorized access

This is so tedious, time-consuming and frustrating. I’m all for good security, but there should be an option to start out without (see MongoDB…) to get going quickly, get the migration done first and then worry about security.

I’m giving up for now; no more time. This is a spare time thing and I won’t waste another night on this. Please, make the upgrade path simpler. If I’m not the only one struggling then maybe this is hurting your upgrade rates.